Requirements

GoEdit Requirements

Requirements of GoEdit are depending on the GoEdit Edition and the Plattform on which it is used.

Requirements of GoEdit Editions

Requirements of GoEdit Plattforms

Requirements of GoEdit Editions

GoEdit Native Edition

Following operating systems/distributions are compatible with GoEdit Native Edition:
  • Windows:
    • Windows 7
    • Windows 8 & 8.1
    • Windows 10
  • Mac OS X:
    • Yosemite (10.10.X)
    • El Capitan (10.11.X)
    • Sierra (10.12.X)
  • Linux (64-bit support only):
    • Ubuntu 14.04 (LTS) & 15.04 - Unity
    • KUbuntu 14.04 - KDE 4
    • KUbuntu 15.04 - KDE 5
    • OpenSUSE 13.2 - KDE 3 & XFCE
    • Fedora 22 - Gnome 3
    • (Other Linux distributions and/or other desktop environments may work with or without minor modifications. If you have a specific configuration you want us to test and support, please contact our support team.)
Following browsers are compatible with GoEdit Native Edition:
  • Microsoft Internet Explorer 8 - 11
  • Microsoft Edge 25
  • Google Chrome 40 - 57
  • Mozilla Firefox 34 - 52
  • Apple Safari 6 - 10
  • Other browsers and/or newer versions may work, but are not officially supported until listed here.
In general, a direct communication between browser and the installed GoEdit Native client must be possible in order to enable direct attachment editing with GoEdit.

Requirements of Supported Plattforms

GoEdit for Confluence (Server)

Supported Confluence versions:
  • Confluence (5.7 - 6.4)
  • Only the latest patch-version of a minor branch is supported in Confluence, e.g. the newest 5.0.x, 5.1.x .... 5.10.x

GoEdit for Confluence (Cloud)

Supported Confluence versions: Most recent version of Confluence Cloud.

GoEdit for Drupal Wiki

Supported Drupal Wiki versions:

GoEdit for Jira

Supported Jira versions:
  • JIRA (7.0 - 7.4)
  • Only the latest patch-version of a minor branch is supported in Jira, e.g. the newest 6.0.x, 6.1.x .... 7.2.x